[wikka-community] Kubrick Theme Edit Textarea

Erik Fearing erik.fearing
Mon Mar 29 17:31:06 GMT 2010

I am running wikka using a modified Kubrick theme.  My users have been
complaining (and it bugs me, too) that the textarea on edit pages is
too small for comfortable use.  It leaves just a little more than
seven lines of text visible.  As best I can tell, it should be showing
100 rows. I have seen odd behavior from the element before, where
resizing the window caused the textarea to grow to the 20 row size -
but I don't remember what browser it was in, and I can't get it to
repeat now.

I've tried editting the wikka/handlers/edit.php file, with no
success...here is the section I've tried to change:

$output .=
'<input type="hidden" name="previous" value="'.$previous.'" />'."\n".
// We need to escape ALL entity refs before display so we display them
_as_ entities instead of interpreting them
// hence hsc_secure() instead of htmlspecialchars_ent() which
UNescapes entities!
// JW/2007-02-20: why is this? wouldn't it be  easier for the person
editing to show actual characters instead of entities?
'<div id="textarea_container">'."\n".
'<textarea id="body" name="body" rows="100"
cols="20">'.$this->hsc_secure($body).'</textarea>'."\n".	#427

I removed the rows and cols arguments from the textarea line, but it
had no effect.  I've also tried changing the values, but that also has
no effect.

I've also worked with the stylesheet quite a bit, and although I can
get the textarea container to get bigger (for example 500px height)
the texarea itself stays small.
Here's the section I've been altering in the style sheet, kubrick.css:

/* editor textarea decorations */
/* (decorations can't be in "textarea#body" declaration, else the
"width:100%" won't work) */
#textarea_container {
?border: 1px solid #CCC;
?height: 500px;
?padding: 2px;
?margin-bottom: 2px;
?width: 100%;
?height: 490px;
?/* padding and border must be 0 for the "width:100%" to work */
?padding: 0;
?border: 0;

On the suspicion that something else I did in replacing graphics and
such caused the problem, I checked out the demo wikkawiki, and when
the theme is set to Kubrick there, edit pages display the same
unmanageably short textarea.

My modified theme is saved in the plugins/templates/ directory - I
copied the kubrick directory there before starting my edits, as
suggested in the themes documentation.  I am not using the
plugins/handlers/ directory.

The wiki is at http://www.kingdom-arcadia.com/lore/.

Any help would be greatly appreciated.

More information about the community mailing list