[wikka-community] can't upload files as non-admin

Mike Shultz mike
Wed Apr 28 16:33:22 GMT 2010

On 04/14/2010 10:02 PM, Felipe Alvarez wrote:
> http://pastebin.com/fUjBUp64
> I can't find documentation on google, and "grep" turns up nothing
> regarding "intranet"
> I am only in an intranet, my server DOES NOT have internet
> connectivity whatsoever. My users are 100% trustable (you nor I should
> doubt that - it's a non-issue). I want ALL users (admin and non-admin)
> to upload files via the Wiki interface. At the moment they are using
> 'scp' to moves the files to ./uploads dir. But this isn't totally
> feasible.
> How do I enable "INTRANET_MODE"? I tried
> // files.php
> But that doesn't do the trick.

I've also tried this out with no luck.  I've tried both of these in

$wakkaConfig['intranet_mode'] = '1';
define('INTRANET_MODE', true);

There's also no reference in the code to 'intranet_mode' and the only
reference to 'intranet' is in the comments of files.php.

After some fiddling, I found what you can do, is comment out the if
statements that check for isAdmin(), like so:

Change line 177 from this: if($this->IsAdmin() && $can_upload_files) {
To this: if($can_upload_files) {

And comment out lines 317, 318, and 342.

That's what I did and all works out fine.

Mike Shultz
Information Technology Assistant
Project Vote Smart

Phone: 406-859-8683
Toll Free: 1-888-VOTE-SMART
Jabber/Gtalk: shultzm at gmail.com
Key Server: pgp.mit.edu

More information about the community mailing list