[wikka-community] community Digest, Vol 23, Issue 2

Brian Koontz brian
Sat Nov 8 00:31:30 GMT 2008

On Fri, Nov 07, 2008 at 07:22:14PM -0500, Alok Mohindra wrote:
> Hey Tormond,
> Thanks for the quick response. I tried your approach but it broke all my
> existing wiki links. No biggie as it is a new installation. I re-installed
> from scratch being careful to keep the base url clean and that url_rewrite
> is enabled, but now I am getting a '404 Not Found Error' when I go to '
> http://wiki.arkalumen.com/HomePage'

Alok, your server mod_rewrite installation appears to be broken.  It doesn't
appear to be a WikkaWiki problem.

I can resolve this just fine:


This indicates a working WikkaWiki installation.  The links on the
wiki appear as:


This indicates that you have (as Tormod pointed out) set "rewrite_mode
=> '1'" in your wikka.config.php.  This is also working correctly.

However, your server is not resolving these links correctly.  You need
to fix mod_rewrite on your server. 

Post your .htaccess file here (just the part after <IfModule
mod_rewrite.c>).  Verify that mod_rewrite is actually enabled on your
server.  Check the suggestions here:

Usually one of the devs is on the IRC channel (freenode, #wikka) if
you want to stop by there.


Brian Koontz
Wikka Development Team
Systems Support and Random Tasking Dept.

More information about the community mailing list